В попытках писать статьи на компьютерную тематику, создается nextontext.ru

Реклама на nextontext.ru

Задача в следующем. Вам важно знать количество символов, которое помещено в той или иной ячейке таблицы. Если вы работаете под Windows, в Excel, то поставленная задача решается очень просто (функция ДЛСТР). Нас же интересует подсчет символов в ячейке при использовании Google Таблиц, и на этот вопрос мы сегодня будем находить ответ. Это намного интереснее, хотя бы потому, что Google Таблицы - это бесплатный инструмент.

Реклама на nextontext.ru



Друзья! Читайте текст до конца. После объяснения примера, я вставил таблицы, задания. Вам нужно будет скопировать их в свои Google Таблицы или Microsoft Excel, чтобы на практике понять, как это работает

В этом цикле статей, я не раз буду повторяться. Google таблицы взяты за основу потому, что они бесплатные. Но, не каждый может ими пользоваться, так как в этом инструменте, функции, идут на английском языке, хотя тут нет ничего сложного. Заходим в Google Таблицы.

Как посчитать символы в ячейке Google таблиц?

Если мы хотим подсчитать, конкретно, в каждой ячейке количество символов, в Google таблицах, достаточно воспользоваться функцией len(). В моем примере есть список фруктов. В клетке ‘B4’ стоит ‘Айва’ = 4 символа. Чтобы подсчитать это через функцию, в строке для формулы необходимо набрать:

=len(B4) - Для Google Таблиц;

=ДЛСТР(B4) - Для Microsoft Office Excel;

Важно! Между функцией и значением пробела нет!

Как посчитать символы в ячейке Google таблиц?

Практическое задание для понимания =len() в Google таблицах

Пройдете несколько шагов и вы поймете как это работает.

1. Зайдите в программу для редактирования Google Таблиц (если вы еще не создали аккаунт в Google, это можно сделать пройдя руководство);

2. Поставьте курсор таблицы в клетку A1;

3. Выделите полностью таблицу ниже, скопируйте в клетку A1;

Строка

Формула

excel

=len(A2)

Подсчитать количество символов

в ячейке

Формула len

4. Поставьте курсор таблицы в клетку B2 - протяните курсор до клетки B5;

протяните курсор до клетки

Помните! Этот пример работает только в Google Таблицах. Если вы используете, Microsoft Excel, замените формулу в клетке B2 на =ДЛСТР(A2).

Подсчитать ячейки с конкретным количеством символов

Представим другую ситуацию, у Вас есть диапазон, в нем есть определенные результаты, а вам необходимо знать, сколько ячеек с конкретным количеством символов, у Вас получилось. Не вопрос, для этого примера, есть специальная функция COUNTIF, в Google таблицах это подсчитывается по следующей формуле:

=COUNTIF(B2:B11;"?????") - Для Google Таблиц;

=СЧЁТЕСЛИ(B2:B11;"?????") - Для Microsoft Office Excel;

Подсчитать ячейки с конкретным количеством символов

Разберемся с тем, что мы набрали:

COUNTIF - это функция, которая подсчитывает в заданном диапазоне, количество ячеек (у нас диапазон B2:B11)

; - разделяет диапазон и условие;

“?????” - это условие. Если мы поставим в кавычках конкретное слово, будет подсчитываться, как часто оно встречается в диапазоне, а так, ищет ячейку с пятью символами. Опять же, если поставить шесть вопросительных знаков, будет подсчитано количество ячеек с шестью знаками.

Практическое задание для понимания =COUNTIF() в Google таблицах

Пройдете несколько шагов и вы поймете как это работает.

1. Зайдите в программу для редактирования Google Таблиц (если вы еще не создали аккаунт в Google, это можно сделать пройдя руководство);

2. Поставьте курсор таблицы в клетку A1;

3. Выделите полностью таблицу ниже, скопируйте в клетку A1;

Строка

Формула

Банан

=COUNTIF(A2:A5;"????")

Азимина

=COUNTIF(A2:A5;"?????")

Айва

=COUNTIF(A2:A5;"??????")

Груша

=COUNTIF(A2:A5;"???????")

Подсчитать ячейки, кроме тех, где содержится конкретное количество символов

Теперь ситуация меняется в обратную сторону. Нам нужно произвести подсчет в диапазоне, всех ячеек, кроме тех, в которых есть пять символов, для этого немного поменяем условия:

=COUNTIF(B2:B11;"<>?????") - Для Google Таблиц;

=СЧЁТЕСЛИ(B2:B11;"<>?????") - Для Microsoft Excel;

COUNTIF и СЧЁТЕСЛИ

Добавление “<>” позволяет исключить из результата, все слова содержащие пять букв, и вернуть количество слов содержащих больше или меньше пяти символов.

Реклама на nextontext.ru

Реклама на nextontext.ru

В том случае, если вы пропустили

Google таблицы. Последний день месяца

Значит, что произошло на прошлой неделе. Я написал пару статей о Microsoft Excel. Хорошие статьи, рассказывали о том, как рассчитать последний день месяца, и находить соответствия в клетках с данными. Насколько эти статьи хорошие, я могу судить по посещаемости (на этих статьях она высокая). Но, вот незадача, статьи с треском провалились в Яндекс Дзен. Конечно, я не расстроился, наоборот, сделал вывод, что алгоритм в “персональных лентах Яндекса”, скорее пьян чем трезв. Поэтому, раз статьи про Excel людям нужны - буду их писать (тем более, мне самому это в огромное удовольствие). Но, будут эти статьи не конкретно про Excel, а про электронные таблицы Google. Вперед, объясню подробнее!

Показать скрытые папки

Ну конечно, скрытые папки и файлы в Windows - это в первую очередь, созданные самим пользователем папки, с контентом, который никто не должен видеть. Это не обеспечит вас защитой от поиска (эти папки и файлы все равно индексируются, а значит попадают в результаты поиска Windows), но значительно усложнит, скорее даже защитит, Ваши конфиденциальные данные от посторонних глаз. Сегодня разбираемся с тем, как создать, показать / скрыть папки и файлы.

Создать аккаунт google

Знаете, такие компании как Google или Яндекс, заинтересованы в том, чтобы их сервисами пользовались. Более того, они заинтересованы, чтобы их сервисами пользовались максимально эффективно. Но, для этого необходимо иметь собственную учетную запись в этих компаниях. Когда вы регистрируетесь в Google, то получаете доступ не только к почте, PlayMarket, личному кабинету YouTube, Календарю или Google Фото. Вы получаете доступ к одному из самых важных сервисов - Google Диску, где можно хранить документы, создавать и редактировать. Сегодня я расскажу о том, как создать аккаунт в Google.

Google таблицы. Функция COUNTIF. Подсчитать положительные и отрицательные числа

Представим, у Вас есть диапазон чисел, в этом диапазоне есть как положительные так и отрицательные числа. Вам важно знать, сколько тех или иных чисел в этом диапазоне. Сегодня как раз с этим и разбираемся. Как подсчитать отрицательные и положительные числа в диапазоне.